Azure App Service application settings not overriding application.json array setting for .NET Core 3.1 application

We have a .NET Core 3.1 application deployed to Microsoft Azure. In the application.json file of the application we have the following contents:

{ "Settings": {     "ServicesURIs": [       {         "Name": "Features",         "URL": "https://abc.azurewebsites.net",         "Port": "443",         "ScopeUri": "api://xxxxxx",         "enabled": "true"       },       {         "Name": "Questions",         "URL": "https://def.azurewebsites.net",         "Port": "443",         "ScopeUri": "api://XXXXX",         "enabled": "true"       }     ]   },   "Logging": {     "LogLevel": {       "Default": "Information",       "Microsoft": "Warning",       "Microsoft.Hosting.Lifetime": "Information"     }   },   "AllowedHosts": "*",   "pwa": {     "cacheId": "v1.3",     "strategy": "networkFirst",     "registerWebmanifest": true,     "routesToPreCache": "/"   } }  

I wish to override the URL properties from the Application settings section in Configuration of the app service in Azure.

I am currently specifying the following application setting in the configuration blade per documentation and lots of online blogs:

Name= Settings:ServicesURIs:0:URL Value= https://Somevalidurl.azurewebsites.net 

But I find that the application is not using the value from the portal configuration, and always try to use the value in the .json file.

I have tried specifying the name as

Settings__ServicesURIs__0__URL 

(where the ":" are replaced with double underscores)

I have restarted the application service after registering the setting in Azure.

I test this using Chrome in Incognito to ensure cache is not playing a role.

Kind regards, Riaan

Add Comment
0 Answer(s)

Your Answer

By posting your answer, you agree to the privacy policy and terms of service.